Session-wide give.spec

/home/cs9999/yyT[0123].work/give.spec
e.g. 23T3.work/give.spec

&#  This is a template file for the give.spec file
&#  in the working directory for the current period.
&#  It is used to set any parameters for the current period.

&#  It must include &assignmap if any assignments are to be submitted.

&#  loginmap
&#  Only needed for "unofficial" mappings (automatic
&#  for normal students with real logins)
&#  entries are 
&#      login  studentID

&loginmap
&end

&# add tutor logins for access to Xmark and sms
&# cs9999 MARK RSMS
&authorisation
xyz MARK RSMS
abc MARK RSMS
cs9999 MARK RSMS
&end

&#  assignmap - added during installation. Entries are
&#      name [aliases...]
&#  where aliases are alternative names that
&#  students can use to identify the assignment

&smsdb = /home/cs9999/12s2.work/12s2db.sms
&# subkey and subgroup describe how to handle submissions
&subkey = stuID
&subgroup = sms tut_lab
&withhold
final_q1
final_q2
final_q3
final_q4
final_q5
&end
&assignmap
assignment
final_q1
final_q2
final_q3
&end

Below are some directives common to the session wide give.spec file:

  • &subkey &subgroup specify how submissions are stored.

    • Individual submissions into tutorial groups
    • Each submission is stored under a directory named after the student's id, which in turn is located under the student's tutorial directory.
    • e.g. $WORK/ass1/mon12a/3123456, ~/08s2.work/assign1/mon12-bell/3123456

      &subkey = stuID
      &subgroup = sms tut_lab
    • to store submissions under student login names, replace &subkey by the following

      &subkey = sms Login
    • Individual submissions where there are no tutorial groups
    • Each submission is stored under a directory named after the student's id, which in turn is located under the all directory.

    • e.g. $WORK/ass1/all

      &subkey = stuID
      &subgroup = none
    • Group submissions into tutorial groups
    • Each submission is stored under a directory named after the group's id, which in turn is located under the group's tutorial directory.
    • e.g. $WORK/ass1/mon12a/123, ~/08s2.work/assign1/mon12-bell/M12A-15

      • ass1, assign1 are assignments; mon12a, mon12-bell are tutorial groups; 123, M12A-15 are group ids;

    • For group work submissions, add the directives (as shown below) to the give.spec file under $WORK/assignment

    • Any member of a group can submit. The submission by a member of a group will override a previous submission by another member of the group. The group ids must be created beforehand in sms.

      &subkey = sms groupID
      &subgroup = sms tut_lab


CategoryGiveSpec

give.spec/session (last edited 2023-09-12 07:49:46 by MeiChengWhale)