&assign = ass1
&comment
  This is a template file for the give.spec file
  in an assignment directory.
  It's used to set all parameters describing the test setup 

 Keywords found here:
        &assign (set by installation script)
        &deadline  (group TAB day/time format)
        &latepen  (as for .latepen)
        &earlybonus (as for .latepen, but opposite time)
        &extension  (as for .extension: studentID days )
        &subkey and &subgroups  (if different from default)
        &subspecs

plus testing module starting with &runspecs
&end


&# default submission: accept HUGS, C (header files optional) or Java/HTML
&subspecs
accept  total_peaks.py max_peak.py peak_list.py peak_list_from_file.py
&end

&# allow current submission and three backup copies only
&backups = 3
&# limit each submission to 250 Kbytes
&maxsize = 250
&smsmark = ass1

&deadline
all Wed 28 Oct 17:00:00 2020 , Mon 02 Nov 09:00:00 2020
&end

&latepen
ceiling %
0 per hour for 1 hour
10 per day for 5 days
&end

&# 1 day extension for 5123456
&extensions
5123456 1
&end

&runspecs
&testmode notests
&compile
rm -fr *.py *.txt *.out __pycache__ marking_system


classify -v $1

tar xf  $A/marking_system.tar 

for f in total_peaks max_peak peak_list peak_list_from_file
do
    if [ -f ${f}.py ]
    then
        dos2unix -q -- ${f}.py
        list ${f}.py
        mv ${f}.py marking_system/${f}/${f}_student.py
    fi
done

&end

&special 2 total_peaks

cwd=`pwd`
cd marking_system

./run_tests.py total_peaks 13 > out.txt
./extract_marks.py out.txt > mark.out

if test -r out.txt
then
        cat out.txt
        MARK=`cat mark.out`
else
        echo
        echo "Auto-marking output not found!"
        echo
        MARK=0
fi

cd $cwd

&end

&special 1 max_peak

cwd=`pwd`
cd marking_system

./run_tests.py max_peak 10 > out.txt
./extract_marks.py out.txt > mark.out

if test -r out.txt
then
        cat out.txt
        MARK=`cat mark.out`
else
        echo
        echo "Auto-marking output not found!"
        echo
        MARK=0
fi

cd $cwd

&end

&special 10 peak_list

cwd=`pwd`
cd marking_system

./run_tests.py peak_list 15 > out.txt
./extract_marks.py out.txt > mark.out

if test -r out.txt
then
        cat out.txt
        MARK=`cat mark.out`
else
        echo
        echo "Auto-marking output not found!"
        echo
        MARK=0
fi

cd $cwd

&end

&special 2 peak_list_from_file

cwd=`pwd`
cd marking_system

./run_tests.py peak_list_from_file 5 > out.txt
./extract_marks.py out.txt > mark.out

if test -r out.txt
then
        cat out.txt
        MARK=`cat mark.out`
else
        echo
        echo "Auto-marking output not found!"
        echo
        MARK=0
fi

cd $cwd

&end

&subjective 5
Style and Complexity    5
&end

&totalmark 20

give.spec/Examples/special2 (last edited 2021-05-24 12:24:05 by MeichengWhale)