Differences between revisions 3 and 9 (spanning 6 versions)
Revision 3 as of 2013-09-11 09:48:26
Size: 2490
Comment:
Revision 9 as of 2020-06-16 17:07:42
Size: 3048
Comment:
Deletions are marked like this. Additions are marked like this.
Line 5: Line 5:
 * '''&subspecs''' - Specify which files are accepted during submission
   * Example 1: Accept allocator.c and optionally any .h files and any other .c files.
 * ~+'''`&subspecs`'''+~ - Specify which files are accepted during submission
   * Example 1: ~+`accept allocator.c` ''`and optionally any .h files and any other .c files.`''+~
Line 12: Line 12:
   * Example 2: `accept` ''`files1`'' `or` `accept` ''`files2`'' `or ...`    * Example 2: ~+`accept` ''`files1`'' `or` `accept` ''`files2`'' `or ...`+~
Line 21: Line 21:
   * Example 3: reject all    * Example 3: ~+`reject` ''`all`''+~
Line 27: Line 27:
   `reject *` to stop submissions. Used when automarking prac where the submissions come from the exam account    ~+`reject *`+~ to stop submissions. Used when automarking prac where the submissions come from the exam account
Line 29: Line 29:
 * '''&deadline''' - Specify assignment deadline  * ~+'''`&deadline`'''+~ - Specify assignment deadline
Line 31: Line 31:
  ~+''`group deadline [[, startdate], enddate]`''+~    ~+''`group deadline [[, startdate], enddate]`''+~
Line 33: Line 33:
   * Example 1: Accept submissions any day.    * Example 1: ~+''`Accept submissions any day.`''+~
Line 40: Line 40:
   * Example 2: Accept submissions until a specified date.    * Example 2: ~+''`Accept submissions until a specified date.`''+~
Line 47: Line 47:
   . When student submits after this date, he will get this message:    . When student submits after this date, they will get this message:
Line 54: Line 54:
   * Example 3: Accept submissions from a start date until an end date.    * Example 3: ~+''`Accept submissions from a start date until an end date.`''+~
Line 61: Line 61:
 * '''&latepen/&earlybonus''' - Specify the late penalty or early bonus  * ~+'''`&latepen/&earlybonus`'''+~ - Specify the late penalty or early bonus
Line 70: Line 70:
   . `ceiling` - penalty is reduction in maximum available mark
   . `ceiling %` - penalty is specified as percentages, default is mark
   . `0 per hour for 1 hour` - exempted if less than an hour late
   . `15 per day for 4 days` - 15% of the total mark is deducted from the maximum for each day late
   . ~+`ceiling`+~ - penalty is reduction in maximum available mark
   . ~+`ceiling %`+~ - penalty is specified as percentages, default is mark
   . ~+`0 per hour for 1 hour`+~ - exempted if less than an hour late
   . ~+`15 per day for 4 days`+~ - 15% of the total mark is deducted from the maximum for each day late
Line 83: Line 84:
   . `raw` - change to the raw mark
   . `0 per day for 3 days` - no change to the raw mark if 3 days or less early
   . `1 per day for 1 day` - one mark added to raw mark if 4 days or more early
   . ~+`raw`+~ - change to the raw mark
   . ~+`0 per day for 3 days`+~ - no change to the raw mark if 3 days or less early
   . ~+`1 per day for 1 day`+~ - one mark added to raw mark if 4 days or more early
Line 87: Line 88:
 * '''&extension''' - Add students who need extensions
   * Example:
 * ~+'''`&extension`'''+~ - Add students who need extensions
   * Example 1: ~+''`Specify days late`''+~
Line 95: Line 96:
   * Example 2: ~+''`Specify hours late`''+~
   {{{
&extension
3123456 0:1
&end
   }}}
   The student will get 1 hour extension.

 * ~+'''`&maxsize`'''+~ - Change submission file size
   * Example:
   {{{
# 1 MB
&maxsize = 1024
   }}}

 * ~+'''`&backups`'''+~ - Keep previous submissions
   * Example:
   {{{
# current submission and keep the previous three submissions
&backups = 3
   }}}

Submission Specs

  • &subspecs - Specify which files are accepted during submission

    • Example 1: accept allocator.c and optionally any .h files and any other .c files.

      &subspecs
      accept  allocator.c *.h/0+ *.c/0+
      &end
    • Example 2: accept files1 or accept files2 or ...

      &subspecs
      accept  FPView.java readme.txt *.java *.jar/0+ *.jpg/0+ *.png/0+ *.txt/0+ *.fpe/0+
      accept  readme.txt *.h *.cpp *.tem/0+ dsview.pro *.jpg/0+ *.png/0+ *.txt/0+ *.fpe/0+ *.tgz/0
      accept  *.zip readme.txt
      accept  *.tgz readme.txt
      &end
    • Example 3: reject all

      &subspecs
      reject *
      &end

      reject * to stop submissions. Used when automarking prac where the submissions come from the exam account

  • &deadline - Specify assignment deadline

    • group deadline [[, startdate], enddate]

    • Example 1: Accept submissions any day.

      &deadline
      all Tue 23 Sep 09:59:59 
      &end
    • Example 2: Accept submissions until a specified date.

      &deadline
      all Tue 23 Sep 09:59:59, Sun 28 Sep 09:59:59 
      &end
    • When student submits after this date, they will get this message:
      You cannot submit after this date: Sun 28 Sep 09:59:59
      Submission NOT accepted
    • Example 3: Accept submissions from a start date until an end date.

      &deadline
      all Tue 23 Sep 09:59:59, Mon 8 Sep 09:59:59, Sun 28 Sep 09:59:59 
      &end
  • &latepen/&earlybonus - Specify the late penalty or early bonus

    • Example 1:
      &latepen
      ceiling %
      0 per hour for 1 hour
      15 per day for 4 days
      &end
    • ceiling - penalty is reduction in maximum available mark

    • ceiling % - penalty is specified as percentages, default is mark

    • 0 per hour for 1 hour - exempted if less than an hour late

    • 15 per day for 4 days - 15% of the total mark is deducted from the maximum for each day late

    • Example 2:
      &earlybonus
      raw
      0 per day for 3 days
      1 per day for 1 day
      &end
    • raw - change to the raw mark

    • 0 per day for 3 days - no change to the raw mark if 3 days or less early

    • 1 per day for 1 day - one mark added to raw mark if 4 days or more early

  • &extension - Add students who need extensions

    • Example 1: Specify days late

      &extension
      3123456 5
      &end
      The student will get 5 days extension. After 5 days, the usual late penalty applies.
    • Example 2: Specify hours late

      &extension
      3123456 0:1
      &end
      The student will get 1 hour extension.
  • &maxsize - Change submission file size

    • Example:
      # 1 MB
      &maxsize = 1024
  • &backups - Keep previous submissions

    • Example:
      # current submission and keep the previous three submissions
      &backups = 3

give.spec/subspecs (last edited 2020-08-14 07:06:11 by MeichengWhale)