Differences between revisions 1 and 6 (spanning 5 versions)
Revision 1 as of 2013-01-08 12:13:59
Size: 2467
Comment:
Revision 6 as of 2014-10-22 17:07:13
Size: 2753
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
== Submission == #acl All:read

== Submission Specs ==
Line 93: Line 95:

 * '''&maxsize''' - Change submission file size
   * Example:
   {{{
# 1 MB
&maxsize = 1024
   }}}

 * '''&backups''' - Keep previous submissions
   * Example:
   {{{
# current submission and keep the previous three submissions
&backups = 3
   }}}

Submission Specs

  • &subspecs - Specify which files are accepted during submission

    • Example 1: Accept allocator.c and optionally any .h files and any other .c files.
      &subspecs
      accept  allocator.c *.h/0+ *.c/0+
      &end
    • Example 2: accept files1 or accept files2 or ...

      &subspecs
      accept  FPView.java readme.txt *.java *.jar/0+ *.jpg/0+ *.png/0+ *.txt/0+ *.fpe/0+
      accept  readme.txt *.h *.cpp *.tem/0+ dsview.pro *.jpg/0+ *.png/0+ *.txt/0+ *.fpe/0+ *.tgz/0
      accept  *.zip readme.txt
      accept  *.tgz readme.txt
      &end
    • Example 3: reject all
      &subspecs
      reject *
      &end

      reject * to stop submissions. Used when automarking prac where the submissions come from the exam account

  • &deadline - Specify assignment deadline

    • group deadline [[, startdate], enddate]

    • Example 1: Accept submissions any day.
      &deadline
      all Tue 23 Sep 09:59:59 
      &end
    • Example 2: Accept submissions until a specified date.
      &deadline
      all Tue 23 Sep 09:59:59, Sun 28 Sep 09:59:59 
      &end
    • When student submits after this date, he will get this message:
      You cannot submit after this date: Sun 28 Sep 09:59:59
      Submission NOT accepted
    • Example 3: Accept submissions from a start date until an end date.
      &deadline
      all Tue 23 Sep 09:59:59, Mon 8 Sep 09:59:59, Sun 28 Sep 09:59:59 
      &end
  • &latepen/&earlybonus - Specify the late penalty or early bonus

    • Example 1:
      &latepen
      ceiling %
      0 per hour for 1 hour
      15 per day for 4 days
      &end
    • ceiling - penalty is reduction in maximum available mark

    • ceiling % - penalty is specified as percentages, default is mark

    • 0 per hour for 1 hour - exempted if less than an hour late

    • 15 per day for 4 days - 15% of the total mark is deducted from the maximum for each day late

    • Example 2:
      &earlybonus
      raw
      0 per day for 3 days
      1 per day for 1 day
      &end
    • raw - change to the raw mark

    • 0 per day for 3 days - no change to the raw mark if 3 days or less early

    • 1 per day for 1 day - one mark added to raw mark if 4 days or more early

  • &extension - Add students who need extensions

    • Example:
      &extension
      3123456 5
      &end
      The student will get 5 days extension. After 5 days, the usual late penalty applies.
  • &maxsize - Change submission file size

    • Example:
      # 1 MB
      &maxsize = 1024
  • &backups - Keep previous submissions

    • Example:
      # current submission and keep the previous three submissions
      &backups = 3

give.spec/subspecs (last edited 2020-08-14 07:06:11 by MeichengWhale)