Differences between revisions 2 and 3
Revision 2 as of 2014-03-11 05:55:52
Size: 1688
Comment:
Revision 3 as of 2020-06-16 17:24:59
Size: 1691
Comment:
Deletions are marked like this. Additions are marked like this.
Line 3: Line 3:
* '''&subkey and &subgroup'''  * ~+'''`&subkey` `&subgroup`'''+~
Line 7: Line 7:
Line 8: Line 9:
   . e.g. `$WORK/ass1/mon12a/3123456`, `~/08s2.work/assign1/mon12-bell/3123456`    . e.g. ~+`$WORK/ass1/mon12a/3123456`+~, ~+`~/08s2.work/assign1/mon12-bell/3123456`+~
Line 14: Line 15:
  . to store submissions under student login names, replace `&subkey` by the following   . to store submissions under student login names, replace ~+`&subkey`+~ by the following
Line 20: Line 21:
  . Each submission is stored under a directory named after the student's id, which in turn is located under the `all` directory.
  . e.g. `$WORK/ass1/all`

. Each submission is stored under a directory named after the student's id, which in turn is located under the ~+`all`+~ directory.
  . e.g. ~+`$WORK/ass1/all`+~
Line 29: Line 31:
Line 30: Line 33:
  . e.g. `$WORK/ass1/mon12a/123`, `~/08s2.work/assign1/mon12-bell/M12A-15`
    ~-''`ass1`, `assign1` are assignments; `mon12a`, `mon12-bell` are tutorial groups; `123`, `M12A-15` are group ids;''-~
  . e.g. ~+`$WORK/ass1/mon12a/123`+~, ~+`~/08s2.work/assign1/mon12-bell/M12A-15`+~
    ~+`ass1`+~, ~+`assign1`+~ are assignments; ~+`mon12a`+~, ~+`mon12-bell`+~ are tutorial groups; ~+`123`+~, ~+`M12A-15`+~ are group ids;
Line 33: Line 36:
  . For group work submissions, add the directives (as shown below) to the `give.spec` file under `$WORK/`''`assignment`'' or change the directives in the `give.spec` file under `$WORK`.   . For group work submissions, add the directives (as shown below) to the ~+`give.spec`+~ file under ~+`$WORK/`''`assignment`''+~
Line 35: Line 38:
  . Any member of a group can submit. The submission by a member of a group will override a previous submission by another member of the group. The group ids must be created beforehand in `sms`.   . Any member of a group can submit. The submission by a member of a group will override a previous submission by another member of the group. The group ids must be created beforehand in ~+`sms`+~.
  • &subkey &subgroup

  • These directives specify how submissions are stored.
    • Individual submissions into tutorial groups
    • Each submission is stored under a directory named after the student's id, which in turn is located under the student's tutorial directory.
    • e.g. $WORK/ass1/mon12a/3123456, ~/08s2.work/assign1/mon12-bell/3123456

      &subkey = stuID
      &subgroup = sms tut_lab
    • to store submissions under student login names, replace &subkey by the following

      &subkey = sms Login
    • Individual submissions where there are no tutorial groups
    • Each submission is stored under a directory named after the student's id, which in turn is located under the all directory.

    • e.g. $WORK/ass1/all

      &subkey = stuID
      &subgroup = none
    • Group submissions into tutorial groups
    • Each submission is stored under a directory named after the group's id, which in turn is located under the group's tutorial directory.
    • e.g. $WORK/ass1/mon12a/123, ~/08s2.work/assign1/mon12-bell/M12A-15

      • ass1, assign1 are assignments; mon12a, mon12-bell are tutorial groups; 123, M12A-15 are group ids;

    • For group work submissions, add the directives (as shown below) to the give.spec file under $WORK/assignment

    • Any member of a group can submit. The submission by a member of a group will override a previous submission by another member of the group. The group ids must be created beforehand in sms.

      &subkey = sms groupID
      &subgroup = sms tut_lab

give.spec/subkeysubgroup (last edited 2020-08-14 07:07:32 by MeichengWhale)